Posts Maven 빌드시 TLS 오류 발생
Post
Cancel

Maven 빌드시 TLS 오류 발생

회사 테스트용 PC에서 빌드중 에러가 발생하였다. PC 환경은 다음과 같다.

  • Windows 10 Pro x64
  • JDK 1.7(1.7.0_80-b15)
  • Maven 3(3.6.3)

내 랩탑(MBPR 2018)에서는 잘 되는데 테스트용 PC에서 빌드하니 다음과 같은 에러가 발생했다.

maven goal 실행 오류

해당 오류는 Java 1.8 버전에는 TLS 프로토콜의 기본 버전이 1.2인 반면 이전 Java(1.7, 1.6 등)는 TLS 프로토콜의 버전이 1.0이어서 발생한 오류라고 한다(참고).

따라서 maven 실행시 다음과 같은 옵션을 지정하여야 한다.

1
$ mvn -Dhttps.protocols=TLSv1.2 [clean | package ...]

혹은 졸린눈의 포스팅을 참고하면 좋다.

This post is licensed under CC BY 4.0 by the author.

Java short / byte array 변환

스타벅스에 간 할머니

Comments powered by Disqus.